Jump to content


Photo

House of Google 0.0.9.8 [BETA]


  • Please log in to reply
409 replies to this topic

#21 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:40 PM

And ...

 

Away.

 

We.

 

Go.


  • SamuriHL likes this

#22 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:42 PM

oops - full backup didn't complete, I have an iffy cable lol.

 

This is gonna be interesting.  May have to wait a couple of days until my Type-C female to micro USB male adapters come in so I can use my Pixel's cable.

 

We'll see - gonna try it anyway (so, basically, what I am saying is that my chances at bricking just increased by about 1000%....)



#23 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:43 PM

Oh great.  That's awesome. LOL


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#24 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:44 PM

Oh, and my slow-assed system is taking its sweet time checking SHA256.

 

Are you checking the whole .ZIP, or individual files by extraction?  I'd bet on whole .ZIP, but stranger things have happened....



#25 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:45 PM

The zip.  It compares it against Google's posted SHA256 hash.  And yes, it's slow.  I don't care.  I'd rather be safe than sorry. I wanna know that download is good before someone flashes it.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#26 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:46 PM

OK, just used both implbits' HashTab *AND* Hash Check to verify SHA256 on the .ZIP.

 

Why is your utility taking so long again?  Everything is grayed out while the last msg is "Download complete...Checking SHA hash.  This may take a few minutes."



#27 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:47 PM

Cause I'm using MS' built in SHA256 crap.  It's slow but it's not THAT slow.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#28 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:48 PM

Or did you miss the pop up dialog somewhere that tells you it's done?  LMAO


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#29 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:48 PM

Uh...still grayed out dude.



#30 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:49 PM

It will be until the pop up comes up and you click ok.  


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#31 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:50 PM

Or did you miss the pop up dialog somewhere that tells you it's done?  LMAO

 

Yup.  I did.

 

It popper up a tiny box that popped on my main screen, probably while I was typing in Fx here in the forums, or whatever, and so it was underneath everything.

 

Meanwhile, I'm running the utility on my second screen, lol.

 

Believe it or not, this happens with more utilities in Windows than I care to admit....


  • SamuriHL likes this

#32 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:50 PM

Rebooting Shamu to bootloader.

 

it's Magic time.


  • SamuriHL likes this

#33 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:51 PM

Yea I told you the UI was created in MINUTES and needs a ton of work.  That dialog will go away in the next version and I'll simply output the status to the status window.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#34 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:51 PM

Got a failed to write to device (too many links) more than once-  it's not pausing when it should lol - then it pauses for 5 seconds, after throwing up the warning.  (It's because of the cable)

 

This is gonna be fun



#35 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 05:53 PM

WTF....it should be pausing after each of the commands.  I have a feeling I know why.  Damnit.  You might need an update in a few minutes. Good thing is you can start with magic next time since you have a valid image downloaded.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#36 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:55 PM

Done.  Didn't even have to get another cable lol.

 

Attached File  HoG #1.PNG   41.67KB   3 downloads



#37 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:57 PM

OK, so I need to reboot since it is still in BL, test install. 

 

And I suppose that log output comes later after all this other stuff, right?

 

Meanwhile, here is the entire log:

D:\HouseOfGoogle\IMAGES\shamu-n6f27m-factory-bf5cce08.zip
Download complete...Checking SHA hash.  This may take a few minutes.
SHA256 VERIFIED!
Extracting: D:\HouseOfGoogle\IMAGES\shamu-n6f27m-factory-bf5cce08.zip
 To: D:\HouseOfGoogle\IMAGES\NEXUS\
extract: radio-shamu-d4.01-9625-05.45+fsg-9625-02.117.img
extract: image-shamu-n6f27m.zip
extract: bootloader-shamu-moto-apq8084-72.04.img
Extract complete.
Starting flash...

< waiting for any device >
(bootloader) has-slot:bootloader: not found
Sending 'bootloader' (4071 KB)                     OKAY [  0.172s]
Writing 'bootloader'                               (bootloader) flashing partition ...
(bootloader) This may take a few seconds if a
(bootloader) different partition table is being
(bootloader) flashed since we need to backup
(bootloader) and restore a few partitions
(bootloader) Flashing primary GPT image...
(bootloader) Flashing backup GPT image...
(bootloader) flashing aboot ...
(bootloader) flashing sbl1 ...
(bootloader) flashing rpm ...
(bootloader) flashing tz ...
(bootloader) flashing sdi ...
(bootloader) flashing logo ...
OKAY [  0.656s]
Finished. Total time: 0.906s


< waiting for any device >
rebooting into bootloader                          FAILED (Write to device failed (Too many links))
Finished. Total time: 0.094s

Sleep 5 seconds for reboot...

(bootloader) has-slot:radio: not found
Sending 'radio' (115507 KB)                        OKAY [  4.254s]
Writing 'radio'                                    (bootloader) flashing modem ...
(bootloader) flashing mdm1m9kefs1 ...
(bootloader) flashing mdm1m9kefs2 ...
(bootloader) flashing mdm1m9kefs3 ...
(bootloader) flashing versions ...
OKAY [  1.641s]
Finished. Total time: 5.985s


< waiting for any device >
rebooting into bootloader                          FAILED (Write to device failed (Too many links))
Finished. Total time: 0.078s

Sleep 5 seconds for reboot...

< waiting for any device >
extracting android-info.txt (0 MB) to RAM...
--------------------------------------------       
Bootloader Version...: moto-apq8084-72.04
Baseband Version.....: D4.01-9625-05.45+FSG-9625-02.117
Serial Number........: ZY222X6Z3C
--------------------------------------------       
Checking product                                   OKAY [  0.000s]
Checking version-bootloader                        OKAY [  0.000s]
Checking version-baseband                          OKAY [  0.005s]
extracting boot.img (8 MB) to disk... took 0.025s
(bootloader) has-slot:boot: not found
archive does not contain 'boot.sig'
archive does not contain 'dtbo.img'
archive does not contain 'dt.img'
archive does not contain 'odm.img'
archive does not contain 'product.img'
archive does not contain 'product-services.img'
extracting recovery.img (13 MB) to disk... took 0.030s
(bootloader) has-slot:recovery: not found
archive does not contain 'recovery.sig'
archive does not contain 'super.img'
extracting system.img (1544 MB) to disk... took 8.597s
(bootloader) has-slot:system: not found
(bootloader) has-slot:system: not found
archive does not contain 'system.sig'
archive does not contain 'vbmeta.img'
archive does not contain 'vendor.img'
(bootloader) slot-count: not found
Sending 'boot' (8483 KB)                           OKAY [  0.406s]
Writing 'boot'                                     OKAY [  0.172s]
Sending 'recovery' (13873 KB)                      OKAY [  0.531s]
Writing 'recovery'                                 OKAY [  0.188s]
Sending sparse 'system' 1/4 (522524 KB)            OKAY [ 19.920s]
Writing sparse 'system' 1/4                        OKAY [  7.640s]
Sending sparse 'system' 2/4 (517601 KB)            OKAY [ 19.531s]
Writing sparse 'system' 2/4                        FAILED (Status read failed (Too many links))
Finished. Total time: 60.954s

Flash complete.  Thank you for using the House of Google!


  • SamuriHL likes this

#38 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 05:58 PM

lol - this might not be happening - looks like it didn't actually finish, eh?



#39 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:00 PM

Gonna try again, see if it can actually flash the entire system like it is supposed to, instead of manually flashing this time, since it seems to work the way it was intended except for my cable faults.



#40 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:00 PM

It does look like it didn't finish.  Redownload from the original link.  I updated it with a new version.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users