Jump to content


Photo

House of Google 0.0.9.8 [BETA]


  • Please log in to reply
409 replies to this topic

#41 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:06 PM

Lol - it worked second time with build 0.0.1.

 

After it boots, I'll try with new build.

 

Here is log:

Extracting: D:\HouseOfGoogle\IMAGES\shamu-n6f27m-factory-bf5cce08.zip
 To: D:\HouseOfGoogle\IMAGES\NEXUS\
extract: radio-shamu-d4.01-9625-05.45+fsg-9625-02.117.img
extract: image-shamu-n6f27m.zip
extract: bootloader-shamu-moto-apq8084-72.04.img
Extract complete.
Starting flash...

(bootloader) has-slot:bootloader: not found
Sending 'bootloader' (4071 KB)                     OKAY [  0.156s]
Writing 'bootloader'                               (bootloader) flashing partition ...
(bootloader) This may take a few seconds if a
(bootloader) different partition table is being
(bootloader) flashed since we need to backup
(bootloader) and restore a few partitions
(bootloader) Flashing primary GPT image...
(bootloader) Flashing backup GPT image...
(bootloader) flashing aboot ...
(bootloader) flashing sbl1 ...
(bootloader) flashing rpm ...
(bootloader) flashing tz ...
(bootloader) flashing sdi ...
(bootloader) flashing logo ...
OKAY [  0.703s]
Finished. Total time: 0.953s


< waiting for any device >
rebooting into bootloader                          FAILED (Write to device failed (Too many links))
Finished. Total time: 0.078s

Sleep 5 seconds for reboot...

< waiting for any device >
(bootloader) has-slot:radio: not found
Sending 'radio' (115507 KB)                        OKAY [  4.281s]
Writing 'radio'                                    (bootloader) flashing modem ...
(bootloader) flashing mdm1m9kefs1 ...
(bootloader) flashing mdm1m9kefs2 ...
(bootloader) flashing mdm1m9kefs3 ...
(bootloader) flashing versions ...
OKAY [  1.515s]
Finished. Total time: 5.890s


< waiting for any device >
rebooting into bootloader                          FAILED (Write to device failed (Too many links))
Finished. Total time: 0.094s

Sleep 5 seconds for reboot...

< waiting for any device >
extracting android-info.txt (0 MB) to RAM...
--------------------------------------------       
Bootloader Version...: moto-apq8084-72.04
Baseband Version.....: D4.01-9625-05.45+FSG-9625-02.117
Serial Number........: ZY222X6Z3C
--------------------------------------------       
Checking product                                   OKAY [  0.000s]
Checking version-bootloader                        OKAY [  0.015s]
Checking version-baseband                          OKAY [  0.000s]
extracting boot.img (8 MB) to disk... took 0.024s
(bootloader) has-slot:boot: not found
archive does not contain 'boot.sig'
archive does not contain 'dtbo.img'
archive does not contain 'dt.img'
archive does not contain 'odm.img'
archive does not contain 'product.img'
archive does not contain 'product-services.img'
extracting recovery.img (13 MB) to disk... took 0.035s
(bootloader) has-slot:recovery: not found
archive does not contain 'recovery.sig'
archive does not contain 'super.img'
extracting system.img (1544 MB) to disk... took 8.588s
(bootloader) has-slot:system: not found
(bootloader) has-slot:system: not found
archive does not contain 'system.sig'
archive does not contain 'vbmeta.img'
archive does not contain 'vendor.img'
(bootloader) slot-count: not found
Sending 'boot' (8483 KB)                           OKAY [  0.406s]
Writing 'boot'                                     OKAY [  0.156s]
Sending 'recovery' (13873 KB)                      OKAY [  0.516s]
Writing 'recovery'                                 OKAY [  0.219s]
Sending sparse 'system' 1/4 (522524 KB)            OKAY [ 20.037s]
Writing sparse 'system' 1/4                        OKAY [  7.563s]
Sending sparse 'system' 2/4 (517601 KB)            OKAY [ 20.010s]
Writing sparse 'system' 2/4                        OKAY [  7.143s]
Sending sparse 'system' 3/4 (508949 KB)            OKAY [ 19.590s]
Writing sparse 'system' 3/4                        OKAY [  7.095s]
Sending sparse 'system' 4/4 (32756 KB)             OKAY [  1.254s]
Writing sparse 'system' 4/4                        OKAY [  0.387s]
Rebooting                                          
Finished. Total time: 95.812s

Flash complete.  Thank you for using the House of Google!


  • SamuriHL likes this

#42 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:09 PM

Damn that's impressive.  A version 0.0.0.0.0.0.0.0 actually worked.  I gotta be happy about that.  What did you think of this new process?  :D


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#43 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:11 PM

So, interesting tidbit with my funky cable issues.

 

In BL mode, without a cable attached, it usually has written at the very bottom "Attach USB Cable".

 

In the middle of the output, in green, is written Battery level, and it says OK.

 

If I attach a cable, sometimes it will register at the bottom as USB cable attached.  Sometimes not.

 

However, as long as it shows Battery level OK (charging) in the green line, then the utility (and all fastboot commands and adb commands) will work.

 

I was looking at the bottom and jiggling the cable left and right trying to get that USB Cable attached message to come up - turns out I don't need to see it (meaning the system doesn't actually need to be fully aware that a data cable has been attached, as long as it is charging and (of course) connected to my USB port and not the charger!).

 

Food for thought.


  • SamuriHL likes this

#44 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:13 PM

Damn that's impressive.  A version 0.0.0.0.0.0.0.0 actually worked.  I gotta be happy about that.  What did you think of this new process?  :D

 

Pretty cool.  Just waiting for the phone to actually boot lol.

 

Of course, it *is* Shamu - so it is notorious for slow boot times after a flash.

 

Oh, and don't hate me - but I connected it to my USB 3 (well, actually, to a USB 3 hub that is connected to one of my USB 3 ports).



#45 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:15 PM

OMFG through a HUB?  A USB 3 HUB????  You really are asking for trouble aren't you?  LMAO


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#46 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:16 PM

The main thing - the automation.  It's 10X easier than doing it yourself, and yet it is doing exactly everything you normally should do with flashing a Factory image, including the things that most people skip doing:  Hash check.

 

I suppose it will not be too hard to hard code a n IMAGES folder for the images to reside in, since you extract to the device folder name anyway, right?

 

Also, wonder if it will work with symbolic links / junctions - because if it does, I always keep the latest Factory images, OTA images, and binaries for all my devices (both of them, really) lcoally, but in separate folders based upon device name.

 

If I just link / make a junction to them in a folder, thing it will work fine?   :lol :ph34r :blink


  • SamuriHL likes this

#47 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:17 PM

OMFG through a HUB?  A USB 3 HUB????  You really are asking for trouble aren't you?  LMAO

 

powered USB 3 hub - and it's because my USB 2 connections are all wonky, except 1 from the front panel (KB) and the one from the onboard header (connected to my 75-1 Card reader).

 

Besides, other than the cable itself being wonky, I've had 0 issues with using USB 3 for the Shamu - unlike ever before on Windows 10....


  • SamuriHL likes this

#48 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:20 PM

Ugh.  Still booting.....

 

I love my Shamu, don't get me wrong.

 

But the first time I booted my Taimen, I found a million things (almost literally) wrong with the Shamu that they got right with Taimen.

 

The bootup process is by far one of the top three.



#49 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:21 PM

The main thing - the automation.  It's 10X easier than doing it yourself, and yet it is doing exactly everything you normally should do with flashing a Factory image, including the things that most people skip doing:  Hash check.

 

I suppose it will not be too hard to hard code a n IMAGES folder for the images to reside in, since you extract to the device folder name anyway, right?

 

Also, wonder if it will work with symbolic links / junctions - because if it does, I always keep the latest Factory images, OTA images, and binaries for all my devices (both of them, really) lcoally, but in separate folders based upon device name.

 

If I just link / make a junction to them in a folder, thing it will work fine?   :lol :ph34r :blink

 

Yea should work fine doing that.  And yes I like the automation, as well.  I gotta write the OTA side of things now. I'll be able to test that on my own.  There's a few other things that need to be added.  Options to wipe data, select the slot, etc.  We'll get there. The fact that it's flashing is AMAZING.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#50 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:23 PM

Ugh.  Still booting.....

 

I love my Shamu, don't get me wrong.

 

But the first time I booted my Taimen, I found a million things (almost literally) wrong with the Shamu that they got right with Taimen.

 

The bootup process is by far one of the top three.

 

Loved the whale but I do like my Pixel XL.  Works very well.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#51 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:23 PM

I've seen the Android logo 3 times, but it keeps going back to the curly-cues.



#52 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:25 PM

Lovely....hopefully it's not due to the flash.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#53 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:26 PM

Yea should work fine doing that.  And yes I like the automation, as well.  I gotta write the OTA side of things now. I'll be able to test that on my own.  There's a few other things that need to be added.  Options to wipe data, select the slot, etc.  We'll get there. The fact that it's flashing is AMAZING.

 

Oh, $#!+, this is gonna be fun....

 

I use Link Shell Extension to easily create SLs, junctions, etc - gonna try multiple ways to do it and see which works best (I suppose junction the parent folder for each type of image will work just fine, just have to be able to tell it manually where to find the file, after you code that function in lol).

 

TBH, I sort of assumed you'd have it create a dir structure like you did with the prev gen Houses, inside the extracted HoG folder.  Is that still the plan, or you gonna make us users actually do some of the work?



#54 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:26 PM

I was gonna try with the new version and see, but I might manually flash right now and see if it is the flash or the device....



#55 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:30 PM

Hmmm.  The Shamu image I have saved is hte T-Mo one, n8i11f, but the one that I DLd through HoG is the generic n6f27m.

 

I suspect something didn't get wiped correctly.

 

Time to boot TWRP, wipe *everything*, then load the BL and try again with ver 0.0.0.0.1



#56 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:31 PM

Oh, shit, this is gonna be fun....

 

I use Link Shell Extension to easily create SLs, junctions, etc - gonna try multiple ways to do it and see which works best (I suppose junction the parent folder for each type of image will work just fine, just have to be able to tell it manually where to find the file, after you code that function in lol).

 

TBH, I sort of assumed you'd have it create a dir structure like you did with the prev gen Houses, inside the extracted HoG folder.  Is that still the plan, or you gonna make us users actually do some of the work?

 

Undetermined.  We're at the design stage still.  This thing's getting an actual installer at some point, too.  And for my own sanity an official build process, git repo, and all that.  LOTS of work to be done. This was mostly just a proof of concept that the idea could work....that being a program that can drive everything including flashing.  It'll take care of its own platform tools when I'm done and all that fun stuff.  But the basics are good!


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#57 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:32 PM

I DO NOT wipe data so that might explain it.  I haven't added that option yet.


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#58 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:37 PM

Undetermined.  We're at the design stage still.  This thing's getting an actual installer at some point, too.  And for my own sanity an official build process, git repo, and all that.  LOTS of work to be done. This was mostly just a proof of concept that the idea could work....that being a program that can drive everything including flashing.  It'll take care of its own platform tools when I'm done and all that fun stuff.  But the basics are good!

 

Funny you mention that  I was talking with a buddy at lunch, and it got me wondering if you were gonna maintain a repository at github or somewhere else for this.

 

Now I know.

 

And as for platform tools - lol - if you can DL the actual image, for that many dif devices, you can surely dl the latest PTs, as well as anything else that the user might need to get this all done, I already knew that.  I already believed that that was gonna be in the works, no questions asked.

 

I DO NOT wipe data so that might explain it.  I haven't added that option yet.

 

Oh, yeah, that might be it then.  Time to play.

 

I saved both versions thus far release - want me to try with the original aught version again, or go ahead and use the new one?


  • SamuriHL likes this

#59 SamuriHL

SamuriHL

    Android Warrior

  • Smod
  • 34,357 posts
  • Current Device(s):Pixel XL

Posted 27 February 2019 - 06:43 PM

Always forward, never back. :)


  • johnlgalt likes this

5uWEQs7.jpg

 

Non potest esse nisi unus

 


#60 johnlgalt

johnlgalt

    Antidisestablishmentarianist

  • Superuser
  • 4,431 posts
  • Twitter:https://twitter.com/JohnLGalt
  • Google+:google.com/+JohnLGalt_1
  • Location3rd Rock
  • Current Device(s):Pixel 2 XL 128 GB (shipping)

Posted 27 February 2019 - 06:45 PM

lol - uh, with symbolic links, it created the Nexus folder where the originals are stored.

 

Let me try hardlinks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users