Jump to content


Photo

[Bootstrap] Safestrap For Cdma Razr [02/28: Version 1.09] [Bugfix]

recovery bootstrap

  • Please log in to reply
49 replies to this topic

#1 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 28 February 2012 - 08:34 PM

SAFESTRAP 1.09 for CDMA RAZR (XT912) (2nd-System Bootstrap / Recovery)

[ After installation boot into recovery and make a FULL backup while in Non-Safe mode to have a full 1st and 2nd system backup for disaster recovery. ]

** INSERT STANDARD DISCLAIMER: I'm not responsible for any damage you do to your phone using my tools. **


[ Make sure you get the RAZR version ]

Please Login or Register to see this Hidden Content


Please Login or Register to see this Hidden Content



[2012-02-28 UPDATE]:
- [2012-02-28 10pm pst] Reposted w/ the correct version showing in the app.
- Fixed webtop restore so that it doesn't break the webtop's partition signature and send you to the fastboot screen on the next reboot.



Entry to recovery via Splashscreen on boot-up. The screen stays up for around 8-10 seconds and if you hit the menu button, it takes you to Safestrap Recovery.

SPECIAL THANKS TO:

  • Koush who develops such a GREAT recovery system and the makes the source available for others to use.
  • The Atrix dev team who I pulled the internal/external SD card support from
  • The Defy dev team that originally developed the Bootmenu source which I stripped down and used for the Splashscreen.
As always, let me know what you think!

Edited by DarkestSpawn, 13 March 2012 - 04:09 AM.
Fixed link to new blogs

  • got556 and tucstwo like this

#2 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 28 February 2012 - 08:37 PM

RESERVED FOR FUTURE USE

#3 (TSON)

(TSON)

    Droid Master

  • Members
  • PipPipPip
  • 529 posts

Posted 28 February 2012 - 08:56 PM

App still says 1.08 :c

But thanks for the update!

#4 jumemoto

jumemoto

    n00b

  • Members
  • Pip
  • 6 posts

Posted 28 February 2012 - 09:31 PM

It does say 1.08 after installing but when I booted up into recovery it said I was running 1.09 so I'm not sure why it says that

#5 jumemoto

jumemoto

    n00b

  • Members
  • Pip
  • 6 posts

Posted 28 February 2012 - 09:45 PM

When I try to boot after toogling into safe mode it wont boot up only shows a blank screen.. what do I do?? anyone else having this problem?

edit: I had to toggle back into nonsafe mode to get the phone to boot up.. am I just impatient and need to wait longer for it to boot?

#6 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 28 February 2012 - 10:02 PM

Fixed the version #. You can re-download and install so that the version check works correctly. Don't need to reinstall the recovery.

#7 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 28 February 2012 - 10:02 PM

When I try to boot after toogling into safe mode it wont boot up only shows a blank screen.. what do I do?? anyone else having this problem?

edit: I had to toggle back into nonsafe mode to get the phone to boot up.. am I just impatient and need to wait longer for it to boot?


Which ROM is giving you this issue?

#8 jumemoto

jumemoto

    n00b

  • Members
  • Pip
  • 6 posts

Posted 28 February 2012 - 10:06 PM

I'm still on the stock rom. I just rooted and then installed safestrap that's it. I saw another guy had the same problem he posted on the blog

#9 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 28 February 2012 - 10:18 PM

I'm still on the stock rom. I just rooted and then installed safestrap that's it. I saw another guy had the same problem he posted on the blog


Did you install a ROM while in Safe mode? You'll need to flash something before it'll boot.

#10 jumemoto

jumemoto

    n00b

  • Members
  • Pip
  • 6 posts

Posted 28 February 2012 - 10:32 PM

Oh no I didn't ok I see so basically there is nothing on the 2nd part and i just need to flash a rom to it? That makes a lot of sense lol

#11 phaim

phaim

    n00b

  • Members
  • Pip
  • 19 posts
  • Twitter:phaim11

Posted 28 February 2012 - 10:35 PM

Hey Hashcode, thanks for the great work. I have a question for you (please forgive me if someone's already asked this). Is it possible to have the 1st and 2nd systems save to the external SD Card instead of the Internal emmc? Unfortunately Google Music's stashing all the music I save for offline use (stupid subways) on the Internal emmc and it's causing a serious space shortage for me. Of course, if you had any ideas about how to force Google Music to post offline music to the external SD Card that'd work fine too!

Thanks man

#12 got556

got556

    Droid Master

  • Members
  • PipPipPip
  • 452 posts
  • Twitter:@got556
  • LocationChicago

Posted 28 February 2012 - 10:58 PM

w00t w00t! Thanks Hash, you're a great asset to this community!
Posted Image

#13 Agoofydiver

Agoofydiver

    n00b

  • Members
  • Pip
  • 12 posts

Posted 28 February 2012 - 11:18 PM

For some reason it's not telling me that recovery is installed nor that I'm in safe mode even though it is for both. Rebooted into recovery says 1.09 and it backed up just fine. Any ideas?

Sent from my DROID RAZR using Tapatalk

#14 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 29 February 2012 - 12:01 AM

For some reason it's not telling me that recovery is installed nor that I'm in safe mode even though it is for both. Rebooted into recovery says 1.09 and it backed up just fine. Any ideas?

Sent from my DROID RAZR using Tapatalk


You could try redownloading the APK. I didn't have the version #'s correct (recovery was fine).



Hey Hashcode, thanks for the great work. I have a question for you (please forgive me if someone's already asked this). Is it possible to have the 1st and 2nd systems save to the external SD Card instead of the Internal emmc? Unfortunately Google Music's stashing all the music I save for offline use (stupid subways) on the Internal emmc and it's causing a serious space shortage for me. Of course, if you had any ideas about how to force Google Music to post offline music to the external SD Card that'd work fine too!

Thanks man


Yeah I see this as a current issue. All of the ICS ROMs use /sdcard as the default for storage. I'll see what I can find. The bad news is that the internal storage will be used even more in the 2.0 version of safestrap that I'm working on. It creates full image file systems which are mounted as /system and /data replacements. but the speed from the external SD card isn't reliable enough.

#15 mrhacks

mrhacks

    Member

  • Members
  • PipPip
  • 55 posts
  • LocationFlorida Keys

Posted 29 February 2012 - 04:12 AM

wOOt! Hash thanks for the update.

Do I need to uninstall v1.08 before I install v1.09 or will it install on top of previous version?

#16 nevildev

nevildev

    Member

  • Members
  • PipPip
  • 32 posts

Posted 29 February 2012 - 05:19 AM

Thanks for the update! I was on 1.08 and successfully updated from axiom rom... no need to uninstall and reinstall mrhacks

Sent from my AOKP AXI0M [R] using Tapatalk

#17 mrhacks

mrhacks

    Member

  • Members
  • PipPip
  • 55 posts
  • LocationFlorida Keys

Posted 29 February 2012 - 05:32 AM

Thanks for the update! I was on 1.08 and successfully updated from axiom rom... no need to uninstall and reinstall mrhacks

Sent from my AOKP AXI0M [R] using Tapatalk

Thanks

#18 brandonspell08

brandonspell08

    n00b

  • Members
  • Pip
  • 24 posts
  • Locationdallas, tx

Posted 29 February 2012 - 06:35 AM

Awsome hashcode.

Thanx for the wonderful program

Sent from my DROID RAZR using Tapatalk

#19 Agoofydiver

Agoofydiver

    n00b

  • Members
  • Pip
  • 12 posts

Posted 29 February 2012 - 07:23 AM

You could try redownloading the APK. I didn't have the version #'s correct (recovery was fine).

/>



Yeah I see this as a current issue. All of the ICS ROMs use /sdcard as the default for storage. I'll see what I can find. The bad news is that the internal storage will be used even more in the 2.0 version of safestrap that I'm working on. It creates full image file systems which are mounted as /system and /data replacements. but the speed from the external SD card isn't reliable enough.

Tried downloading it a couple more times. It keeps doing the same thing. No big deal. I toggled between safe and unsafe modes just fine and everything is working. Just isn't saying it correctly in the Safestrap menu for me. I know it's installed and that safe mode is active.

#20 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 29 February 2012 - 11:11 AM

Sorry I was fail yesterday and missed the version #'s in the APK. I reposted the download file with that correction:

Please Login or Register to see this Hidden Content



#21 patchm00

patchm00

    Member

  • Members
  • PipPip
  • 48 posts

Posted 29 February 2012 - 11:25 AM

SAFESTRAP 1.09 for CDMA RAZR (XT912) (2nd-System Bootstrap / Recovery)

[ After installation boot into recovery and make a FULL backup while in Non-Safe mode to have a full 1st and 2nd system backup for disaster recovery. ]


So, previous backups (with 1.08 safestrap) can still restore correct?

Also, one thing I am confused on is when it asks me if I want to include webtop in the backup and I say no (since I do not use it). I am assuming I can still restore from that correct? The reason I ask, is i tried to restore Eclips 1.2 from a backup (without webtop) and kept getting black screen. Then I restored and said yes to restore webtop (even though I did not back it up) and after some errors it finished and it then booted fine :P

#22 cbraud

cbraud

    n00b

  • Members
  • Pip
  • 1 posts

Posted 29 February 2012 - 11:39 AM

I keep getting a force close whenever i try to open :(

#23 drumtrucker

drumtrucker

    Member

  • Members
  • PipPip
  • 44 posts

Posted 01 March 2012 - 11:08 PM

So, previous backups (with 1.08 safestrap) can still restore correct?

Also, one thing I am confused on is when it asks me if I want to include webtop in the backup and I say no (since I do not use it). I am assuming I can still restore from that correct? The reason I ask, is i tried to restore Eclips 1.2 from a backup (without webtop) and kept getting black screen. Then I restored and said yes to restore webtop (even though I did not back it up) and after some errors it finished and it then booted fine :P


I also want to know webtop or not. Saw somewhere that you should not restore a webtop backup.

I don't use or plan to use (at this point anyway)
Steve B

#24 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 02 March 2012 - 08:24 PM

With 1.09 it is safe to backup and restore webtop. The option is given because backing up webtop creates a HUGE file on the SD (700mb?).

Oddly, you don't need to include webtop in your backups. So I'm not sure why patchm00 was having issues with his restore.

#25 drumtrucker

drumtrucker

    Member

  • Members
  • PipPip
  • 44 posts

Posted 02 March 2012 - 09:42 PM

so really no need to backup webtop, good to know.
phone rooted and safestrap installed, now to decide what rom to try... hmm.
Steve B

#26 drumtrucker

drumtrucker

    Member

  • Members
  • PipPip
  • 44 posts

Posted 02 March 2012 - 11:36 PM

crap, flashed eclipse and think i am in boot loop.. was I supposed to wipe? safe mode had not been used before.
Steve B

#27 Hashcode

Hashcode

    King-Of-Code

  • Developer
  • 227 posts
  • Twitter:Hashcode0f

Posted 03 March 2012 - 08:36 AM

crap, flashed eclipse and think i am in boot loop.. was I supposed to wipe? safe mode had not been used before.


Still need to wipe when flashing.. It's just like any other recovery.

#28 honeydesean

honeydesean

    Member

  • Members
  • PipPip
  • 30 posts

Posted 03 March 2012 - 09:06 AM

How do I switch between Safestrap and Bootstrap? I'm hoping there's a way other than flashing everything back to stock.
RAZR Maxx - Two steps forward (Maxx>>>Droid1) and one step back (My bootloader! What have they done to you!?!)

#29 patchm00

patchm00

    Member

  • Members
  • PipPip
  • 48 posts

Posted 03 March 2012 - 09:11 AM

With 1.09 it is safe to backup and restore webtop. The option is given because backing up webtop creates a HUGE file on the SD (700mb?).

Oddly, you don't need to include webtop in your backups. So I'm not sure why patchm00 was having issues with his restore.


Just did it again (restored Eclipse 1.3 w/no webtop) and got the black screen sitting. Shut down, re-restored, again no webtop and it worked fine. Dunno, either something weird with my sd card or my timing is not very good :)

#30 got556

got556

    Droid Master

  • Members
  • PipPipPip
  • 452 posts
  • Twitter:@got556
  • LocationChicago

Posted 04 March 2012 - 03:57 PM

Just installed the apk and when opening it states Old Version installed and Safe System active. I just hit install recovery and it worked flawlessly! (I was on 1.08 w/ Axiom AB4 running)
Posted Image





Also tagged with one or more of these keywords: recovery, bootstrap

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users