Jump to content


Photo
- - - - -

Help! Camera is not detected at all!

camera not detected fix help razr m

  • Please log in to reply
7 replies to this topic

#1 zansyabana

zansyabana

    n00b

  • Members
  • Pip
  • 5 posts

Posted 19 February 2015 - 09:23 PM

So I've been having the camera not detected problems. It seems that the rear camera is the culprit. Front camera works fine and no problem. I was on 4.4.2 183.46.10, rooted it, unlock bootloader, and using custom roms ever since. I've tried factory reset, back to stock rom, but no help.

 

Then, i've decided to flash 4.4.2 183.46.15 with RSD Lite. It gets worse. The camera cannot be started at all. Rear and back. Even any flashlight app doesn't show camera flash option. Just the screen brightness option. It seems like after the flash my RAZR M detected as a phone with no camera at all. I am very frustrated. It makes me unable to use whatsapp on the web as it requires me to scan the QR Code and any operations that requires camera. Any help suggestion would be very apreciated. Thanks.



#2 spainter

spainter

    Droid Oracle

  • Moderator
  • 3,339 posts
  • LocationUtah
  • Current Device(s):Pixel 2 XL, Nexus 6, Moto X Pure Edition, 2013 Moto X DE, Droid Razr Maxx HD, 2013 Nexus 7 LTE, LG G Pad X 8.3

Posted 19 February 2015 - 09:51 PM

So I've been having the camera not detected problems. It seems that the rear camera is the culprit. Front camera works fine and no problem. I was on 4.4.2 183.46.10, rooted it, unlock bootloader, and using custom roms ever since. I've tried factory reset, back to stock rom, but no help.

 

Then, i've decided to flash 4.4.2 183.46.15 with RSD Lite. It gets worse. The camera cannot be started at all. Rear and back. Even any flashlight app doesn't show camera flash option. Just the screen brightness option. It seems like after the flash my RAZR M detected as a phone with no camera at all. I am very frustrated. It makes me unable to use whatsapp on the web as it requires me to scan the QR Code and any operations that requires camera. Any help suggestion would be very apreciated. Thanks.

After the upgrade to the .15 version, a lot of people had to do a FDR to clear up problems with some of the hardware.  You may have to bite the bullet and give that a shot.



#3 zansyabana

zansyabana

    n00b

  • Members
  • Pip
  • 5 posts

Posted 19 February 2015 - 11:27 PM

After the upgrade to the .15 version, a lot of people had to do a FDR to clear up problems with some of the hardware.  You may have to bite the bullet and give that a shot.

 

Did that many times from the recovery. Even now I'm on custom rom again. Still the same. Thanks by the way for the reply



#4 livinginkaos

livinginkaos

    I don't know what I'm doing anymore.....

  • Administrator
  • 15,038 posts
  • Google+:Hangouts - livinginkaos@gmail.com
  • LocationOregon
  • Current Device(s):Samsung S8+ / Pixel XL 128gb / iPhone 7+ 256gb / iPad Pro 12.9" / Samsung Chromrbook Plus / Pixel C / Nexus 6p 128gb / Nexus 6 / Nexus 6 on Fi / Nexus 9 / Moto 360^2 / Nvidia Shield TV Pro / Nvidia Shield Tablet / HTC EVODesign on FreedomPop / Chromecast / Surface Pro 3 i7 / Samsung Tab Pro 12.2 / Lenovo Win8 Tab / Eee Slate / '13 Nexus 7

Posted 20 February 2015 - 04:47 AM

Have you dropped your device at any point? Or had it apart to change the LCD? It could be that the ribbon cable has come disconnected.

sent from my N6


b2wvCBn.png

Sig by livinginkaos
Samsung S8+ / Pixel XL 128gb / iPhone 7+ 256gb / iPad Pro 12.9" / Samsung Chromrbook Plus / Pixel C / Nexus 6p 128gb / Nexus 6 / Nexus 6 on Fi / Nexus 9 / Moto 360^2 / Nvidia Shield TV Pro / Nvidia Shield Tablet / HTC EVODesign on FreedomPop / Chromecast / Surface Pro 3 i7 / Samsung Tab Pro 12.2 / Lenovo Win8 Tab / Eee Slate / '13 Nexus 7


#5 xKroniK13x

xKroniK13x

    Member

  • Superuser
  • 284 posts
  • LocationAtlanta, GA
  • Current Device(s):Moto X 2014 Pure Edition || Motorola DROID RAZR M || Archos G9 101 || Microsoft Surface Pro 2 || Chromecast

Posted 21 February 2015 - 09:46 AM

My SO's M has the same issue. Mainly rear camera, after a few tries it will work. Appears hardware related from all things I've troubleshooted.

Sent from my RAZR M on BlissPop Lollipop 5.0.2 from Tapatalk


Moto X 2014 Pure Edition Unlocked on Pure Rooted 5.1
Motorola Droid Razr M Unlocked on Some ROM
Archos G9 101 Developer Edition on Cyanogenmod 11 4.4.3 Unofficial/Stable

#6 zansyabana

zansyabana

    n00b

  • Members
  • Pip
  • 5 posts

Posted 22 February 2015 - 09:45 AM

Have you dropped your device at any point? Or had it apart to change the LCD? It could be that the ribbon cable has come disconnected.

sent from my N6

 

 

My SO's M has the same issue. Mainly rear camera, after a few tries it will work. Appears hardware related from all things I've troubleshooted.

Sent from my RAZR M on BlissPop Lollipop 5.0.2 from Tapatalk

 

Yea i think it's the hardware. I'll try order the replacement camera from ebay



#7 coolabyxt907

coolabyxt907

    n00b

  • Members
  • Pip
  • 21 posts
  • LocationWadsa, Distt.- Gadchiroli. India
  • Current Device(s):xt907

Posted 05 March 2015 - 11:51 AM

I am on custom Rom of lollipop and it's camera is too bad...the of xt907 4 .4.2 was great can I install that camera instead of lollipop camera or keep both...?  Plz let me know sir



#8 xKroniK13x

xKroniK13x

    Member

  • Superuser
  • 284 posts
  • LocationAtlanta, GA
  • Current Device(s):Moto X 2014 Pure Edition || Motorola DROID RAZR M || Archos G9 101 || Microsoft Surface Pro 2 || Chromecast

Posted 05 March 2015 - 01:41 PM

I am on custom Rom of lollipop and it's camera is too bad...the of xt907 4 .4.2 was great can I install that camera instead of lollipop camera or keep both...? Plz let me know sir


Just download the Motocamera and install it. Works fine on BlissPop.

This link was on xda. I've used it in the passed.

Please Login or Register to see this Hidden Content



Sent from my RAZR M on BlissPop Lollipop 5.0.2 from Tapatalk


Moto X 2014 Pure Edition Unlocked on Pure Rooted 5.1
Motorola Droid Razr M Unlocked on Some ROM
Archos G9 101 Developer Edition on Cyanogenmod 11 4.4.3 Unofficial/Stable





Also tagged with one or more of these keywords: camera, not detected, fix, help, razr m

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users